根据输入的正整数y所代表的年份,计算输出该年份是否为闰年 闰年的判断标准:
能够被4整除且不能被100整除的年份
或者能够被400整除的年份
输入格式:
输入n取值范围是 【1..3000】
输出格式:
是闰年,输出 yes
非闰年,输出 no
输入样例:
在这里给出一组输入。例如:
100
输出样例:
在这里给出相应的输出。例如:
no
答案
import java.util.Scanner;
public class Main {
public static void main(String[] args)
{
Scanner in=new Scanner(System.in);
int num=in.nextInt();
if ((num%400==0)||(num%4==0 && num%100!=0)) {
System.out.println("yes");
}
else {
System.out.println("no");
}
}
}
易错点:if语句同时判断多个多个条件时没加括号,优先级出现问题,导致出错
答案仅供参考,如有更优解,可在评论区参与讨论
Comments NOTHING